Summit stand broke - Graybeard Outdoors
 
LinkBack Thread Tools
post #1 of 3 (permalink) Old 12-13-2009, 08:48 PM Thread Starter
Member
 
Join Date: Dec 2008
Posts: 831
Default Summit stand broke

I have a Summit Viper that is around 5 years old. I noticed today that the weld that holds the diagonal brace where it meets the platform broke. I don't know how this happened. Any ideas? Have you ever heard of this happening before? Now I need a new tree stand.
forestclimber is offline  
Sponsored Links
Advertisement
 
post #2 of 3 (permalink) Old 12-14-2009, 01:10 AM
Member
 
Join Date: Dec 2007
Posts: 770
Default Re: Summit stand broke

at least you are paying attention

you can't really trust ANYTHING

take the time to check it

being rich and driving a wheelchair is not worth the money

as for the climber that is aluminum so its gonna wear at some point, its light and brittle

Though taken from established manufacturers' sources and presumed to be safe please do not use any load that I have posted. Please reference Hogdon, Lyman, Speer and others as a source of data for your own use.
john keyes is offline  
post #3 of 3 (permalink) Old 12-15-2009, 09:27 PM Thread Starter
Member
 
Join Date: Dec 2008
Posts: 831
Default Re: Summit stand broke

I called Summit. They are sending me another platform. Good company.
forestclimber is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Graybeard Outdoors forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome