Lyman Gen 6 dispenser problem - Graybeard Outdoors
 
LinkBack Thread Tools
post #1 of 8 (permalink) Old 03-05-2019, 09:33 AM Thread Starter
Member
 
omegahunter's Avatar
 
Join Date: Jul 2010
Location: Daviess County, Indiana
Posts: 990
Default Lyman Gen 6 dispenser problem

I have already emailed Lyman about this, but thought that someone else may have experience with the same thing...

I have had this Lyman for 4 years and 2 months. NEVER had the first issue with it until last night. It might drift a 1/10th of a grain once in a while while running charges to which I just re-calibrate, but never any real issues.

Could not get the unit to calibrate. Kept giving me a "Cal 0" reading on the screen and beeped. Let it sit for over an hour and still got the same thing. In the meantime I noticed that the weight readout had drifted by several grains. Here is what seems really fishy... when lifting the 50 gram calibration weight or resetting it in its place on the machine the readout would shift. Same would happen when setting the breeze shield over the cell. Any touching of the machine housing would cause a shift on the readout. It has never done this before. Previously the only way to change the readout was more or less powder on the pan.

The Lyman is always unplugged after use, warmed up for the minimum 3 minutes or longer, and has not been moved from its spot on the bench in the entire time that I have had it.

The bench that it is on is isolated from the press bench and from the other bench with the shotgun loading presses.

While I am waiting on a response from Lyman, has anyone ever heard of or had this happening? This may be one of the farthest reaching websites, so I was just wanting to see if anyone else had any experiences with this. Thanks.

Still living under the curse, but one of these days I will shed this body, be clothed with an immortal one, and everything will be good.
omegahunter is offline  
Sponsored Links
Advertisement
 
post #2 of 8 (permalink) Old 03-06-2019, 07:53 AM Thread Starter
Member
 
omegahunter's Avatar
 
Join Date: Jul 2010
Location: Daviess County, Indiana
Posts: 990
Default

Lyman emailed back suggesting to wipe it down with window cleaner to eliminate any static charge, pull the pan off to check for powder under the pan and to see if the mounting stem was in the center of the recess, and then to pick it up and give it a shake to listen for loose powder inside the machine.

Last night I started with checking the power supply with my multi-meter: good. Then I removed the pan to reveal not a single kernel of powder under it. The mounting stem was still centered in the recess under the pan. The only thing that I did not do was the wipedown for static electricity.
So I plug it back in and did NOT let it go through its normal 3 minute warmup. I immediately got the unit to calibrate and it did not drift. Back to the weird part about the readout changing when anything was touching the unit housing... that was not reproducible last night after it calibrated.

So there was either something up with the way the pan was on the stem (which had never been removed before) or the power adapter into the unit wasn't making good connection and did again after I checked to make sure the transformer was outputting correctly. But you would think that if it would power up that would not have been the cause. But all I know is that it is back to working and I really did nothing to "fix" it. Stumped as to what was the root cause!

Still living under the curse, but one of these days I will shed this body, be clothed with an immortal one, and everything will be good.
omegahunter is offline  
post #3 of 8 (permalink) Old 03-08-2019, 06:43 AM
Moderator
 
lloyd smale's Avatar
 
Join Date: Nov 2002
Location: Munising MI
Posts: 19,640
Default

my guess is there was a kernel of powder or dirt stuck in the wrong place that you just didnt see. Maybe on the inside of the case.

MAKE AMERICA GREAT AGAIN! STEEL FOR TANKS NOT FENCES!!!
lloyd smale is offline  
Sponsored Links
Advertisement
 
post #4 of 8 (permalink) Old 03-17-2019, 07:33 AM
Moderator
 
lloyd smale's Avatar
 
Join Date: Nov 2002
Location: Munising MI
Posts: 19,640
Default

not on my lyman but on my pact I had a transformer cause me some headaches. Come to find out they have two different voltage transformers. One for the scale and one of the the dispenser. I had them switched and got some strange readings. If cleaning doesn't cure it try a new transformer. there pretty cheap at radio shack.

MAKE AMERICA GREAT AGAIN! STEEL FOR TANKS NOT FENCES!!!
lloyd smale is offline  
post #5 of 8 (permalink) Old 03-17-2019, 01:44 PM
Super Moderator
 
land_owner's Avatar
 
Join Date: Jun 2005
Location: Live - Cocoa, FL; Hunt - Mims, FL; Lk. Poincette, FL; Union, SC
Posts: 9,290
Gun Cabinet
Send a message via Skype™ to land_owner
Default

Is Radio Shack still in business? They closed their local store and I had thought they closed them all.
land_owner is offline  
post #6 of 8 (permalink) Old 03-17-2019, 02:31 PM
Senior Member
 
Join Date: Oct 2011
Location: alabama
Posts: 2,527
Default

Quote:
Originally Posted by land_owner View Post
Is Radio Shack still in business? They closed their local store and I had thought they closed them all.
I think they are all gone , At least they are in my part of Bama .

Dogs look up to us
Cats look down on us
Pigs treat us as equals
Winston Churchill

Last edited by mcbammer; 03-17-2019 at 02:35 PM.
mcbammer is offline  
post #7 of 8 (permalink) Old 03-18-2019, 08:08 AM Thread Starter
Member
 
omegahunter's Avatar
 
Join Date: Jul 2010
Location: Daviess County, Indiana
Posts: 990
Default

Quote:
Originally Posted by mcbammer View Post
I think they are all gone , At least they are in my part of Bama .

I had been told years ago that they were shuttered, but it appears that they have a website and scattered stores across the US.

Still living under the curse, but one of these days I will shed this body, be clothed with an immortal one, and everything will be good.
omegahunter is offline  
post #8 of 8 (permalink) Old 03-19-2019, 07:32 AM
Moderator
 
lloyd smale's Avatar
 
Join Date: Nov 2002
Location: Munising MI
Posts: 19,640
Default

theres one here in my little town. Its a pharmacy/radio shack combination. The main store that was 60 miles from here is closed though.

MAKE AMERICA GREAT AGAIN! STEEL FOR TANKS NOT FENCES!!!
lloyd smale is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Graybeard Outdoors forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in










Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome